Unusual properties behaivor in String Type - Designer, Bug?

Today I just logged into my designer and I realize of a weird behavior in my Vision Property editor, particularly in some strings property type.

Notice those BORDERS in properties and things like CHAR()… but I didn’t write the string ‘char()’
image

This is global for my whole project. Did I actived some property or is this a bug and how can I set it default?
I tried restarting the panels and even the gateway
V8.0.9

If you open the Output Console toolbar, is anything getting logged (repeatedly) when you browse around components/windows? Did you recently do any scripting; on a Power Table, possibly?

1 Like

Yes I did some scripting in power tables, I set the preview mode to play and used my power table but nothings shows in console

Is this a normal behavior when performing scripting in power table?

Have you restarted the designer? I’ve seen this before, usually when some bad component script interrupted the ‘painting’ cycle in the designer. Typically restarting the designer will work, at least until you run into whatever bad script caused painting to break, which should hopefully be logged into the output console.

1 Like

I’ll reset the designer and try to catch this error.
You are saying that something in my script is causing this issue, I think is something within property change event handler script in power table, but I used
if event.propertyName == ‘something’:

I don’t know why this is happening, I’ll keep you online

Yeah, I wouldn’t expect a propertyChange script to be the culprit - more likely, configureCell or configureEditor on the power table, or something in the Paintable Canvas’ extension function, or something along those lines. There’s relatively few places where a custom script is run directly in the painting cycle, but it’s an uncaught exception there that leads to this happening (in my experience).

1 Like

I don’t see any looping, when restart the designer

Well I tried to used configureEditor and Cell, but these functions are a little restrictive since they can’t interact with property references from the root container

And the property editors are still ‘weird’? Huh. Can you get in contact with support? They may be able to see something live that I can’t think of.

Sidebar, but they should be able to - self will be a reference to the power table, and you can still go up to its container with self.parent; if it’s directly on the window then self.parent.someProperty should work fine in those scripts.

2 Likes

that’s true, not seeing the image icon gives a restrictive perspective.
I think I’ll contact support, thanks.
After all, would you give me any advice then using property change in power tables?
Is my script running multiple times without control maybe? Is there another way to perform a script in property change to be more restrictive besides ‘event.propertyName’ ?

I really don’t think your property change script is the problem; it sounds like you’ve got it set up correctly. I think I’m correct about what’s causing it, just not sure where it’s coming from.

1 Like

Thanks @PGriffith, this gives an idea of has is happening, I have a question. Does property name ‘visible’ supports oldValue and newValue? if so, how can I used it.
Also does ‘data’ support oldValue and newValue, if so, how can I used it?
Can you show an example please?

I realized what was happening and I fixed it, thanks

1 Like