Windows 10 touchscreen issue

I have a motor I want to jog. The motor will stay running while the touchscreen button is being pressed. It works fine with a mouse but on a Windows 10 touchscreen it does not recognize a touch until your finger is released. I have tried it on 2 different Windows 10 touchscreens. One is a Getac RX10 tablet and the other is an HP laptop. I got it to work more or less correctly in Windows 7 by disabling the “hold to right click” but that same option in Windows 10 has no effect. Has anyone else experienced this? Im using the “mousePressed” scripting to set the tag value to 1 and the “mouseReleased” to set it back to 0. Has anyone else experienced this? Any help you could give would be greatly appreciated.

While you pressing on the button, move your finger a little bit…

I tried that. Its not an acceptable solution. The operators don’t like it and it especially doesn’t work on small buttons. It would also make it work differently than the Win7 tablet. Since you have seen this issue, do you have any ideas? Like maybe registry changes in the HKEY_CURRENT_USER\Software\Microsoft\Wisp\Touch directory?

Windows 10 and Right-click. The bane of our existence at times… Some things to try:

  • Disable through the Control Panel (Pen and Touch)

  • Registry Key
Computer\HKEY_CURRENT_USER\Software\Microsoft\Wisp\Touch\TouchMode_hold = 3 

And what if you need right click on the touch screen? Like popup menu for example…

Then you will get the opportunity to decide where the priorities for the project are. Windows is the root cause here, as it intercepts everything before Java does.

3 Likes

This Getac RX10 tablet is only being used for running Ignition. It doesn’t need a right click.

Hi Jordon. Thank you for the help. Changing the TouchMode_hold to 3 did have some effect. But it didn’t solve the issue. Now when I press and hold, I get a square box and my “touchscreen test bit” shown at left stays at 0. It should go to 1 on touch and back to 0 on release. It works fine with a mouse. Any other suggestions?

These are my registry settings. There is nothing under the “Pen” key.

Try setting the registry entry to 0. Different sources seem to have different answers for the setting.

I tried changing touchmode_hold to 0,1,2,3. It appears that a value of 0 disables the “touch and hold for right click”. All other values enable it. I also tried changing Touchgate from 1 to 0. That just disables the touchscreen altogether. Changing touchUI from 0 to 1 had no noticeable effect. Any other ideas?

Maybe you should abandon Windows?

I would prefer not to abandon windows. Do you think a phone call to Inductive Automation tech support would help? Its hard to imagine that I am the only one who is having this issue. I would think the “Jog While Button Depressed” would be a fairly common thing. I have used similar control schemes in the past using other HMIs and an early version of Windows. XP or 2000 I believe. Also, going back to Win7 isn’t an option since the company is progressing away from that.

Isn’t that what you were looking for? :confused:

You are not the only one…

What’s interesting is that if you use (I tried) another software, like Siemens WinCC Flexible (which is not SCADA software, but HMI) on the tablet with Windows 7 or Windows 10, there is NO problem with ‘jog buttons’… when you press the button, it gets pressed and button pressed event is fired. When you ‘release’ the button, the release event is fired…

I ended up with the tablet with physical buttons on the side, which you can map to the function keys in Windows. Then, in Ignition, I’m using Client Keystroke Scripts (in Client Event Scripts) to detect for example F1 for forward, F2 for backward, F3 for Up, F4 for down,…

No. Although it disables the right click functionality, it does not register as a button press when you touch the screen. And that is what I really want. To have it register as a “button pressed” when you touch the screen and a “button released” when you remove your finger.

There is an interesting article on the Microsoft Developers website (link below) that mentions using TOUCHEVENTF_DOWN and TOUCHEVENTF_UP. These are C++ commands I believe. I’m not a C programmer but can these be easily ported to run in a Python script?

https://social.msdn.microsoft.com/Forums/en-US/fc7ef4ec-fd32-4167-9c17-6622d1425582/recognizing-a-touchandhold-event-on-a-touchscreen?forum=Vsexpressvb

Given that Microsoft doesn’t care about this issue and for people dealing with it, just wanted to share that I got it fixed installing the eGalaxTouch driver, which lets you really disable the right click feature and enable the long press and hold.

2 Likes

Can you elaborate on this for me? I installed the driver onto the tablet but it’s not recognizing my tablet as a touchscreen controller

The last version of eGalaxTouch (5.14.0.18411) didn’t work for me, I tried an older version that did the trick. I can’t upload files but try this link:
eGalaxTouch 5.14.0.15315