Windows Installer seems to exit after splash screen

I am currently running Maker Edition at home 8.1.12. Attempting to update to latest 8.1.25. I downloaded installer. I moved it to the location Ignition is installed per website instructions.

C:\Program Files\Inductive Automation\Ignition


I attempt to run the installer as Administrator (right click Run as Admin). The Ignition splash screen appears then fades out and nothing happens.

Possible Windows security needs to be disabled or something?

Check the wrapper logs IIRC

Thank you andrews

I have checked all the logs I can find and do not see anything that seems related to installer. Everything seems related to MQTT tags.
Gateway log
Wrapper log

Below is wrapper log from attempted install. I started install.exe after 8:58. Splash screen occurred about 8:58:19.

I included time range 8:57 - 8:59:59 to see before/after

wrapper.log (480.0 KB)

Below a few more things I have tried.

  • Updated Java
  • Running installer with gateway stopped stop-ignition.bat)
  • Uninstall Ignition and then install latest version.
    I saved my project, took backup of gateway, then tried uninstalling Ignition. Same thing happens when trying to uninstall. Splash screen then nothing.