Faulted Connection with Kepware

Hello I am still having trouble connecting KEPServerEX 6.3 to Ignition 7.9.4. I followed the instructions of this video and I still getting a faulted connection.
I have added Ignition as a Trusted clients in Kepware in the OPC UA Configuration Manager in Kepware:

I also applied those changes in Kepware by selecting REINITIALIZE on the administration icon. I have even selected “Stop Runtime Service” and “Start Runtime Service”

On " Windows Firewall with Advanced Security" I created and Inbound and Outbound rule allowing all remote ports for TCP and UDP. So this would ensure that the firewall firewall is not blocking traffic on the port that KEPServerEX is using to communicate.

Then, I have looked into the OPC Connection Status link at the bottom of the OPC Server Connections page…

There, I found this error:

java.lang.Exception: no anonymous token policy found
at org.eclipse.milo.opcua.sdk.client.api.identity.AnonymousProvider.lambda$getIdentityToken$2(AnonymousProvider.java:50)
at java.util.Optional.orElseThrow(Unknown Source)
at org.eclipse.milo.opcua.sdk.client.api.identity.AnonymousProvider.getIdentityToken(AnonymousProvider.java:50)
at org.eclipse.milo.opcua.sdk.client.ClientSessionManager.lambda$activateSession$26(ClientSessionManager.java:388)
at java.util.concurrent.CompletableFuture.uniComposeStage(Unknown Source)
at java.util.concurrent.CompletableFuture.thenCompose(Unknown Source)
at org.eclipse.milo.opcua.sdk.client.ClientSessionManager.activateSession(ClientSessionManager.java:414)
at org.eclipse.milo.opcua.sdk.client.ClientSessionManager.lambda$createSession$24(ClientSessionManager.java:361)
at java.util.concurrent.CompletableFuture.uniWhenComplete(Unknown Source)
at java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(Unknown Source)
at java.util.concurrent.CompletableFuture$Completion.exec(Unknown Source)
at java.util.concurrent.ForkJoinTask.doExec(Unknown Source)
at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(Unknown Source)
at java.util.concurrent.ForkJoinPool.runWorker(Unknown Source)
at java.util.concurrent.ForkJoinWorkerThread.run(Unknown Source)

Any ideas on how fix my faulted connection with Kepware?
Thank you.

1 Like

You've got KEPServer configured to require a username and password but you haven't provided one.


Thank you for your response. I have to figure out what is my username and password, because I don’t remember creating one on Kepware.

Alternatively you can find the setting in KSE that enables anonymous access.

1 Like

Thank you. I got it. This is what I had to do:
I right click on Project and select Properties:

Then I went to OPC UA and on the Client Sessions I changed the “Allow anonymous login” from "No to “Yes” :

Then, after I hit apply and okay, I selected REINITIALIZE on the administration icon


Please secure your connections.

1 Like

Thank you for posting this. I ran into the same situation and you solved it for me. THANK YOU!!


A post was split to a new topic: Kepware Bad_UserAccessDenied

Thankyou, this worked for me as well.

1 Like