Ignition Designer Laucher errors when trying to open a launcher

I am completing the training for ignition and I just installed the Designer Launcher. However when I tried running the Launcher it gives me the error below. Do I need to install anything else for the designer to work?
image

@jcoffman?

When in the Designer Launcher i can see my localhost but when I select them and click open designer I get (Java process launch failed with error code 2: Error: could not find java.dll
Error: Could not find Java SE Run Environment)\

New to ignition software, please help

@Nicholasstarling, I moved your post here, looks like the same error… This post looks only slightly different, possibly related…

Hi @acobos,

Is there anything in the designerlauncher.log with additional details? what version are you on?

Thanks,
JJ Coffman

Hi,

Thanks for the reply.

Ignition is Version: 8.1.2 (b2021020311)
The Launcher says its version 1.1.2

Where do I find the designerlauncher.log? I tried doing a search inside the inductive automation folder in my program files and wasn’t able to find the file.

Thanks,
Andres

It will be in ~/.ignition/clientlauncher-data on the computer you tried to run the launcher on. (~ means the user home directory)

I don’t have a “client launcher” inside the ignition folder

Okay, but that’s not where I told you to look.

Sorry my bad was already looking for it there and just made an assumption.

Here is the area where it shows the error on that file. I would upload the file but I am unable as a new user.

INFO [DesignerLauncher ] [2021/02/25 10:00:08]: Set initial logging level to INFO
INFO [DesignerLauncher ] [2021/02/25 10:00:08]: Updating logging level to INFO
INFO [GatewayConnect ] [2021/02/25 10:00:12]: Attempting to connect to gateway http://localhost:8088…
INFO [LaunchUtil ] [2021/02/25 10:00:13]: Starting Java with the following parameters: C:\Users\arcob.ignition\cache\resources\runtimes\11.0.9\bin\java.exe -classpath C:\Users\arcob.ignition\clientlauncher-data\launchclient.jar -Djavaws.sr.gateway.addr.0=http://localhost:8088 -Djavaws.sr.launchts=1614265213244 -Djavaws.sr.main=com.inductiveautomation.ignition.designer.DesignerStartupHook -Djavaws.sr.platform.edition= -Djavaws.sr.platform.plugins= -Xms64M -Xmx1024M -Djavaws.sr.memory.init=64M -Djavaws.sr.memory.max=1024M -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=false -Djavaws.sr.screen=0 -Djavaws.sr.scope=D com.inductiveautomation.ignition.client.launch.BootstrapSwing
ERROR [LaunchUtil ] [2021/02/25 10:00:14]: Launch Error Occurred: Java process launch failed with error code 2: Error: could not find java.dll
Error: Could not find Java SE Runtime Environment.

try deleting the cached runtime at C:\Users\arcob.ignition\cache\resources\runtimes\11.0.9 so its forced to redownload from the target gateway

8 Likes

Awesome! That worked. Thank you for the help.

I was having the exact same issue, and this fixed my problem as well. Thank you!

Thank you! I, too, was having this issue. Worked for me.

This solution worked for me too, I was getting the error after upgrading from 8.1.3 to 8.1.4.

The problem is that we have multiple ignition servers with the client viewers running on about 50 devices at multiple plants in multiple countries. It has created a huge issue as this process has to be done for each device. Please try to find a better solution.

Thanks, this helped!

Thank you for the help! It fixed my error launching the designer!

Thanks!! the problem was solved.

That path does not exist on my computer.

did you use your own user?
i did find it here, (user = victor)
C:\Users\victor\.ignition\cache\resources\runtimes\11.0.9